JMule project forum
http://forum.jmule.org/

JMule CPU Usage
http://forum.jmule.org/viewtopic.php?f=8&t=699
Page 1 of 1

Author:  backseatman [ Fri Apr 09, 2010 9:51 pm ]
Post subject:  JMule CPU Usage

Hello great members of JMule project,

I encountered some bugs(?) in JMule, more specific Kad I believe, although not sure. Whenever I start a download while being connected to Kad my CPU booms up to 90%-100%, I got a Intel quad core so there should be more than enough power. I'm running Windows 7 x64 at the moment, but I saw the same occur on a 32 bit Windows 7 too.

I got the latest JRE's aswell (6Update19). I know Java is a language that speeds up over time, but this problem seem to still be there no matter how long JMule runs.

[Edit: as writing this, I was going to take a look at the logs, I realized the log file was 170mb, now, only if I could look inside it, 170mb txt file isn't going to open in any text editor(170mb log after 2min JMule use!), I'll try open just a few bytes of it]

JMule version: 0.5.8 Beta

Author:  javajox [ Sat Apr 17, 2010 3:35 pm ]
Post subject:  Re: Kad CPU Usage

Hello,

Thank you for the feedback
I have a Intel quad core with Ubuntu 9.10 OS, at the same time I have the following applications running :
1. JMule with 10-15 active download sessions ( Kad is active too )
2. Vuze with 20-30 active torrents
3. 2 instances of Eclipse
4. Firefox with 25 tabs
5. A few of other small programs running

The CPU load is between 30 - 40%

Author:  backseatman [ Mon Apr 19, 2010 6:20 pm ]
Post subject:  Re: Kad CPU Usage

eMule uses a measly 0-1%, and top 20% at max which is only starting it. I have a 300mb JMule log after 30min usage, don't tell me that's normal or how it supposed to be, it can't possibly be.

I'm not complaining here sir, I just figured theres something wrong.

Edit: Here's two screenshots.

Image | Image

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/